Maximizing IE Shortcut screen upon opening

Chemainiac

New member
Joined
Apr 27, 2011
Messages
11
Reaction score
0
Points
0
For some reason all of my IE Shortcuts are completely closed down upon opening. None of thse shortcuts have the option to maximize screen upon opening as does the core IE Shortcut. Any ideas?
 

Ken Puls

Administrator
Staff member
Joined
Mar 13, 2011
Messages
2,522
Reaction score
6
Points
38
Location
Nanaimo, BC, Canada
Website
www.excelguru.ca
Excel Version(s)
Excel Office 365 Insider
I've seen a few posts about this out there. Try this:

Start IE8, get to the desired size, then do file -> exit (from the menu, not the red x button). It should then startup at the size for now on.

If that doesn't work, let me know and we'll track down another solution.
 

Ken Puls

Administrator
Staff member
Joined
Mar 13, 2011
Messages
2,522
Reaction score
6
Points
38
Location
Nanaimo, BC, Canada
Website
www.excelguru.ca
Excel Version(s)
Excel Office 365 Insider
Hmm...

What operating system are you using? XP, Vista or Windows 7?

If you right click the icon on the desktop, and choose Properties, do you see the option to run "Maximized"?

(The following shot is from a Windows 7 desktop shortcut)
5-11-2011 9-16-52 PM.jpg
 

Chemainiac

New member
Joined
Apr 27, 2011
Messages
11
Reaction score
0
Points
0
XP. None of the desktop shortcuts have the level of detail shown in the screenshot. The IE shortcut on the toolbar does bring up that detail. THis was not a problem a few months ago. Something changed.
 

Ken Puls

Administrator
Staff member
Joined
Mar 13, 2011
Messages
2,522
Reaction score
6
Points
38
Location
Nanaimo, BC, Canada
Website
www.excelguru.ca
Excel Version(s)
Excel Office 365 Insider
I found an article that suggests the following method to work around things.
  • Open a single Internet Explorer window to the smaller size.
  • Drag the corners of the window until it completely fills the screen. (Do not use the maximize button to enlarge the window.)
  • Hold down the Ctrl key, keep it depressed, and using the mouse click File and then Exit on the menu bar. (Do not use the "X" in the upper right corner to close the window)
  • Internet Explorer should now open in a full window.
  • If it still opens to a smaller size repeat the above instructions, substituting the "Shift" key for the "Ctrl" key.
The theory is that IE8 holds the most recent size in it's settings, so this gets close to it.

Let me know if it works. I've also seen a registry hack that might work, but it had mixed reviews...
 

Ken Puls

Administrator
Staff member
Joined
Mar 13, 2011
Messages
2,522
Reaction score
6
Points
38
Location
Nanaimo, BC, Canada
Website
www.excelguru.ca
Excel Version(s)
Excel Office 365 Insider
Here's the registry keys that would need to be edited, according to what I found:

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main
-->delete the "Window_Placement" subkey

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Document Window\Maximized
-->change the value of this key to "Yes"

As always, you modify the registry at your own risk. Doing it improperly can cause serious issues with your computer. If you do decide to go there, type Windows+R, type RegEdit and click OK. That will get you in to the registry editor.
 

Chemainiac

New member
Joined
Apr 27, 2011
Messages
11
Reaction score
0
Points
0
SHIFT/CTRL approach failed. I am reluctant to try a registry hack. There has got to be a cleaner solution. This is so bizarre.
 

Ken Puls

Administrator
Staff member
Joined
Mar 13, 2011
Messages
2,522
Reaction score
6
Points
38
Location
Nanaimo, BC, Canada
Website
www.excelguru.ca
Excel Version(s)
Excel Office 365 Insider
Hi there,

I would agree, although I'd bet the issue is buried in the registry since that's where most settings are stored. The frustrating part is that, in all my searching, I haven't found a way to modify it through the user interface. I'm really not sure what else to offer. :(
 

Chemainiac

New member
Joined
Apr 27, 2011
Messages
11
Reaction score
0
Points
0
I sincerely approciate the effort. I may have to try the registry hack in the end. Very strange.
 

WorkTracker

New member
Joined
May 31, 2011
Messages
1
Reaction score
0
Points
0
Try this code...

I have been having similar problems with IE9 not opening maximised, so I wrote a short bit of code for AutoIt and this is described on my website at http://www.worktracker.co.uk/internet-explorer-tips

The compiled version is also there, so you can pull it down and run it in the background and whenever Internet Explorer is the top window, it will maximise it for you as fast as you can blink!

Hope it helps,
Alan
 
Top