count formula with condition

choco8

New member
Joined
Mar 11, 2012
Messages
1
Reaction score
0
Points
0
i need some help. any can give formula of counta function that can count values.
For examples, data 1,2,4,6,8,9,10,3,4,2,3,1,. i want to count how many are in-
a) are 8 to 10
b) 4 to 7
c) below 3.

thanks for your help.
 

maninweb

New member
Joined
Mar 22, 2011
Messages
88
Reaction score
0
Points
0
Location
Germany
Website
excel-translator.de
Excel Version(s)
2010, 2016, 2016 Insider
Hi choco8...

you can try following formulas, if the values are in cells A1 to A12...

a) =SUMPRODUCT((A1:A12>=8)*(A1:A12<=10))
b) =SUMMENPRODUKT((A1:A12>=4)*(A1:A12<=7))
c) =COUNTIF(A1:A12,"<3")

Regards :)
 

Bob Phillips

Super Moderator
Staff member
Joined
Mar 21, 2011
Messages
1,942
Reaction score
0
Points
36
Excel Version(s)
O365
If you have Excel 2007 or 2010, use COUNTIFS

=COUNTIFS(A1:A12,">=8",A1:A12,"<=10")

If not then

=COUNTIF(A1:A12,">=8")-COUNTIF(A1:A12,">10")
 
Top